"receive_packet failed on ath0: Network is down" during DHCP request with an associated AP

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

"receive_packet failed on ath0: Network is down" during DHCP request with an associated AP

David Ehrmann
When udhcpc (or dhclient) tries to make a request, I usually get this
shortly after:

receive_packet failed on ath0: Network is down
l2_packet_receive - recvfrom: Network is down

The advice I found from searching for the error was to make sure I'm
associated, and I am:

ath0      IEEE 802.11g  ESSID:"..."  Nickname:""
          Mode:Managed  Frequency:2.412 GHz  Access Point: ...
          Bit Rate:36 Mb/s   Tx-Power=28 dBm   Sensitivity=1/1
          Retry:off   RTS thr=1 B   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=40/70  Signal level=-59 dBm  Noise level=-99 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

I can also associate with a secure version of that AP and get an
encryption key with wpa_supplicant, but I still get the same error.

I can successfully associate with an request an IP address from some
other AP.  Since this worked before, and I didn't change any settings,
this seemed like an AP issue, but I thought I should see if I missed
something.


-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Madwifi-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/madwifi-users