madwifi + minstrel stuck at lowest rate.

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

madwifi + minstrel stuck at lowest rate.

Joe Hershberger
Hi,

I'm having an issue with the minstrel rate algorithm in madwifi r4133
and linux 2.6.30 not selecting a rate that is greater than 1 Mbps.  If
I select a fixed rate of 54 Mbps i get much faster throughput.

Looking at the rate_info, it seems that the algorithm is not getting
the feedback it needs.  I'm guessing there is something that is not
plumbed quite right.

Here's that that looks like:

~ # cat /proc/net/madwifi/ath0/rate_info
rate data for node:: 00:25:9c:2a:c8:06
rate     throughput  ewma prob   this prob  this succ/attempt
success    attempts
TtP  1         0.0        0.0        0.0          0(  0)          0           0
     2         0.0        0.0        0.0          0(  0)          0           0
     5.5       0.0        0.0        0.0          0(  0)          0           0
     6         0.0        0.0        0.0          0(  0)          0           0
     9         0.0        0.0        0.0          0(  0)          0           0
    11         0.0        0.0        0.0          0(  0)          0           0
    12         0.0        0.0        0.0          0(  0)          0           0
    18         0.0        0.0        0.0          0(  0)          0           0
    24         0.0        0.0        0.0          0(  0)          0           0
    36         0.0        0.0        0.0          0(  0)          0           0
    48         0.0        0.0        0.0          0(  0)          0           0
    54         0.0        0.0        0.0          0(  0)          0           0

Total packet count::    ideal 31      lookaround 3

The ideal and lookaround packet counts are changing so it is trying.

The machine is a Freescale MPC8313 (powerpc 603e) and the wireless
card is a mini-PCI Silex SX-10WG (AR5005G).

The following in the dmesg traces I get on modprobe:

~ # modprobe ath_pci ratectl=minstrel
wlan: svn r4133 (branch madwifi-0.9.4)
ath_hal: module license 'Proprietary' taints kernel.
Disabling lock debugging due to kernel taint
ath_hal: 0.9.18.0 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413,
RF5413, REGOPS_FUNC)
ath_pci: svn r4133 (branch madwifi-0.9.4)
ath_rate_minstrel: Minstrel automatic rate control algorithm 1.2 (svn
r4133 (branch madwifi-0.9.4))
ath_rate_minstrel: Look around rate set to 10%
ath_rate_minstrel: EWMA rolloff level set to 75%
ath_rate_minstrel: Max Segment size in the mrr set to 6000 us
wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps
24Mbps 36Mbps 48Mbps 54Mbps
wifi0: H/W encryption support: WEP AES AES_CCM TKIP
wifi0: mac 7.8 phy 4.5 radio 5.6
wifi0: Use hw queue 1 for WME_AC_BE traffic
wifi0: Use hw queue 0 for WME_AC_BK traffic
wifi0: Use hw queue 2 for WME_AC_VI traffic
wifi0: Use hw queue 3 for WME_AC_VO traffic
wifi0: Use hw queue 8 for CAB traffic
wifi0: Use hw queue 9 for beacons
wifi0: Atheros 5212: mem=0x90000000, irq=48

Thanks for any suggestions,
-Joe

------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
Madwifi-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/madwifi-users
Loading...