Quantcast

Issue to see ath0 after building madwifi on Debian

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Issue to see ath0 after building madwifi on Debian

Cayetanot, Sebastien

Hi All,

 

I’m currently facing an issue to get ath0 up and ready to be used.

 

I have a laptop using the debian 5 with a kernel 2.6.26-2-686

 

I have downloaded linux header/src for this kernel.

 

I have followed the madwifi starting guide to get the driver source and tools packages, I have build the drivers and ath_pci.ko and ath_hal.ko are both built.

 

I have used the command “modprob ath_pci” to load the driver (and also using the insmod command for ath_hal an ath_pci).

 

But I still not see the interface ath0 using the iwconfig or “ifconfig –a” tools.

 

I have checked using “lspci” that an Atheros card is listed and it’s the case. à Netwrok Controller: Atheros Communication Inc. Device 002a

 

Any idea?

 

Seb

---------------------------------------------------------------------
Intel Corporation SAS (French simplified joint stock company)
Registered headquarters: "Les Montalets"- 2, rue de Paris,
92196 Meudon Cedex, France
Registration Number:  302 456 199 R.C.S. NANTERRE
Capital: 4,572,000 Euros

This e-mail and any attachments may contain confidential material for
the sole use of the intended recipient(s). Any review or distribution
by others is strictly prohibited. If you are not the intended
recipient, please contact the sender and delete all copies.


------------------------------------------------------------------------------
Own the Future-Intel® Level Up Game Demo Contest 2013
Rise to greatness in Intel's independent game demo contest.
Compete for recognition, cash, and the chance to get your game
on Steam. $5K grand prize plus 10 genre and skill prizes.
Submit your demo by 6/6/13. http://p.sf.net/sfu/intel_levelupd2d
_______________________________________________
Madwifi-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/madwifi-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Issue to see ath0 after building madwifi on Debian

Cayetanot, Sebastien

By the way, is it normal that lspci do not reply  that it’s a wireless device and not only “Netwrok Controller: Atheros Communication Inc. Device 002a”

 

Seb

 

From: Cayetanot, Sebastien
Sent: Tuesday, March 26, 2013 1:07 PM
To: '[hidden email]'
Subject: Issue to see ath0 after building madwifi on Debian

 

Hi All,

 

I’m currently facing an issue to get ath0 up and ready to be used.

 

I have a laptop using the debian 5 with a kernel 2.6.26-2-686

 

I have downloaded linux header/src for this kernel.

 

I have followed the madwifi starting guide to get the driver source and tools packages, I have build the drivers and ath_pci.ko and ath_hal.ko are both built.

 

I have used the command “modprob ath_pci” to load the driver (and also using the insmod command for ath_hal an ath_pci).

 

But I still not see the interface ath0 using the iwconfig or “ifconfig –a” tools.

 

I have checked using “lspci” that an Atheros card is listed and it’s the case. à Netwrok Controller: Atheros Communication Inc. Device 002a

 

Any idea?

 

Seb

---------------------------------------------------------------------
Intel Corporation SAS (French simplified joint stock company)
Registered headquarters: "Les Montalets"- 2, rue de Paris,
92196 Meudon Cedex, France
Registration Number:  302 456 199 R.C.S. NANTERRE
Capital: 4,572,000 Euros

This e-mail and any attachments may contain confidential material for
the sole use of the intended recipient(s). Any review or distribution
by others is strictly prohibited. If you are not the intended
recipient, please contact the sender and delete all copies.


------------------------------------------------------------------------------
Own the Future-Intel® Level Up Game Demo Contest 2013
Rise to greatness in Intel's independent game demo contest.
Compete for recognition, cash, and the chance to get your game
on Steam. $5K grand prize plus 10 genre and skill prizes.
Submit your demo by 6/6/13. http://p.sf.net/sfu/intel_levelupd2d
_______________________________________________
Madwifi-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/madwifi-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Issue to see ath0 after building madwifi on Debian

Pavel Roskin
On Tue, 26 Mar 2013 15:00:20 +0000
"Cayetanot, Sebastien" <[hidden email]> wrote:

> By the way, is it normal that lspci do not reply  that it's a
> wireless device and not only "Netwrok Controller: Atheros
> Communication Inc. Device 002a"

It looks like a typo in the lspci source or device database.

> I have used the command "modprob ath_pci" to load the driver (and
> also using the insmod command for ath_hal an ath_pci).
>
> But I still not see the interface ath0 using the iwconfig or
> "ifconfig -a" tools.

You may have another driver claiming the device, most likely ath9k.  It
needs to be removed by rmmod for ath_pci to claim the device.

Check the kernel log with the dmesg command.  The driver may have
trouble initializing the device.

You may also have an old version of MadWifi without AR9280 support.
Please always specify the version of the software if reporting a
problem with it.

--
Regards,
Pavel Roskin

------------------------------------------------------------------------------
Own the Future-Intel&reg; Level Up Game Demo Contest 2013
Rise to greatness in Intel's independent game demo contest.
Compete for recognition, cash, and the chance to get your game
on Steam. $5K grand prize plus 10 genre and skill prizes.
Submit your demo by 6/6/13. http://p.sf.net/sfu/intel_levelupd2d
_______________________________________________
Madwifi-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/madwifi-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Issue to see ath0 after building madwifi on Debian

Cayetanot, Sebastien
Sorry Madwifi I'm using is the one from trunk. Supposed to be close to 0.9.4 release

-----Original Message-----
From: Pavel Roskin [mailto:[hidden email]]
Sent: Tuesday, March 26, 2013 5:36 PM
To: Cayetanot, Sebastien
Cc: [hidden email]
Subject: Re: [Madwifi-users] Issue to see ath0 after building madwifi on Debian

On Tue, 26 Mar 2013 15:00:20 +0000
"Cayetanot, Sebastien" <[hidden email]> wrote:

> By the way, is it normal that lspci do not reply  that it's a wireless
> device and not only "Netwrok Controller: Atheros Communication Inc.
> Device 002a"

It looks like a typo in the lspci source or device database.

> I have used the command "modprob ath_pci" to load the driver (and also
> using the insmod command for ath_hal an ath_pci).
>
> But I still not see the interface ath0 using the iwconfig or "ifconfig
> -a" tools.

You may have another driver claiming the device, most likely ath9k.  It needs to be removed by rmmod for ath_pci to claim the device.

Check the kernel log with the dmesg command.  The driver may have trouble initializing the device.

You may also have an old version of MadWifi without AR9280 support.
Please always specify the version of the software if reporting a problem with it.

--
Regards,
Pavel Roskin
---------------------------------------------------------------------
Intel Corporation SAS (French simplified joint stock company)
Registered headquarters: "Les Montalets"- 2, rue de Paris,
92196 Meudon Cedex, France
Registration Number:  302 456 199 R.C.S. NANTERRE
Capital: 4,572,000 Euros

This e-mail and any attachments may contain confidential material for
the sole use of the intended recipient(s). Any review or distribution
by others is strictly prohibited. If you are not the intended
recipient, please contact the sender and delete all copies.


------------------------------------------------------------------------------
Own the Future-Intel&reg; Level Up Game Demo Contest 2013
Rise to greatness in Intel's independent game demo contest.
Compete for recognition, cash, and the chance to get your game
on Steam. $5K grand prize plus 10 genre and skill prizes.
Submit your demo by 6/6/13. http://p.sf.net/sfu/intel_levelupd2d
_______________________________________________
Madwifi-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/madwifi-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Issue to see ath0 after building madwifi on Debian

Cayetanot, Sebastien
In reply to this post by Pavel Roskin
The release I got, is the one delivered by debian 5 through apt-get.

I get the source code from madwifi website also but I do not succeed to compile due to an issues related to "implicit declaration of function'__skb_append' in ieee80211_power.c

I'm need to stay in debian 5 and use madwifi driver. I know that madwifi is no more supported starting debian 6 and we have to replace it by ath5k/ath9k


Regards

-----Original Message-----
From: Pavel Roskin [mailto:[hidden email]]
Sent: Tuesday, March 26, 2013 5:36 PM
To: Cayetanot, Sebastien
Cc: [hidden email]
Subject: Re: [Madwifi-users] Issue to see ath0 after building madwifi on Debian

On Tue, 26 Mar 2013 15:00:20 +0000
"Cayetanot, Sebastien" <[hidden email]> wrote:

> By the way, is it normal that lspci do not reply  that it's a wireless
> device and not only "Netwrok Controller: Atheros Communication Inc.
> Device 002a"

It looks like a typo in the lspci source or device database.

> I have used the command "modprob ath_pci" to load the driver (and also
> using the insmod command for ath_hal an ath_pci).
>
> But I still not see the interface ath0 using the iwconfig or "ifconfig
> -a" tools.

You may have another driver claiming the device, most likely ath9k.  It needs to be removed by rmmod for ath_pci to claim the device.

Check the kernel log with the dmesg command.  The driver may have trouble initializing the device.

You may also have an old version of MadWifi without AR9280 support.
Please always specify the version of the software if reporting a problem with it.

--
Regards,
Pavel Roskin
---------------------------------------------------------------------
Intel Corporation SAS (French simplified joint stock company)
Registered headquarters: "Les Montalets"- 2, rue de Paris,
92196 Meudon Cedex, France
Registration Number:  302 456 199 R.C.S. NANTERRE
Capital: 4,572,000 Euros

This e-mail and any attachments may contain confidential material for
the sole use of the intended recipient(s). Any review or distribution
by others is strictly prohibited. If you are not the intended
recipient, please contact the sender and delete all copies.


------------------------------------------------------------------------------
Own the Future-Intel&reg; Level Up Game Demo Contest 2013
Rise to greatness in Intel's independent game demo contest.
Compete for recognition, cash, and the chance to get your game
on Steam. $5K grand prize plus 10 genre and skill prizes.
Submit your demo by 6/6/13. http://p.sf.net/sfu/intel_levelupd2d
_______________________________________________
Madwifi-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/madwifi-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Issue to see ath0 after building madwifi on Debian

Cayetanot, Sebastien
In reply to this post by Pavel Roskin
Ok , I have patched the source code of the madwifi driver to replace skb_append by skb_queue_after and the build succeed.

Now, when I load the ath_hal module, I got a reply in dmesg with: ath_hal: 0.9.18.0 (AR5210....)

But when loading the ath_pci module, I got a list of "unknown symbol ieeexxx" and "disagrees about version of symbol and FATAL error to load the module

 

-----Original Message-----
From: Pavel Roskin [mailto:[hidden email]]
Sent: Tuesday, March 26, 2013 5:36 PM
To: Cayetanot, Sebastien
Cc: [hidden email]
Subject: Re: [Madwifi-users] Issue to see ath0 after building madwifi on Debian

On Tue, 26 Mar 2013 15:00:20 +0000
"Cayetanot, Sebastien" <[hidden email]> wrote:

> By the way, is it normal that lspci do not reply  that it's a wireless
> device and not only "Netwrok Controller: Atheros Communication Inc.
> Device 002a"

It looks like a typo in the lspci source or device database.

> I have used the command "modprob ath_pci" to load the driver (and also
> using the insmod command for ath_hal an ath_pci).
>
> But I still not see the interface ath0 using the iwconfig or "ifconfig
> -a" tools.

You may have another driver claiming the device, most likely ath9k.  It needs to be removed by rmmod for ath_pci to claim the device.

Check the kernel log with the dmesg command.  The driver may have trouble initializing the device.

You may also have an old version of MadWifi without AR9280 support.
Please always specify the version of the software if reporting a problem with it.

--
Regards,
Pavel Roskin
---------------------------------------------------------------------
Intel Corporation SAS (French simplified joint stock company)
Registered headquarters: "Les Montalets"- 2, rue de Paris,
92196 Meudon Cedex, France
Registration Number:  302 456 199 R.C.S. NANTERRE
Capital: 4,572,000 Euros

This e-mail and any attachments may contain confidential material for
the sole use of the intended recipient(s). Any review or distribution
by others is strictly prohibited. If you are not the intended
recipient, please contact the sender and delete all copies.


------------------------------------------------------------------------------
Own the Future-Intel&reg; Level Up Game Demo Contest 2013
Rise to greatness in Intel's independent game demo contest.
Compete for recognition, cash, and the chance to get your game
on Steam. $5K grand prize plus 10 genre and skill prizes.
Submit your demo by 6/6/13. http://p.sf.net/sfu/intel_levelupd2d
_______________________________________________
Madwifi-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/madwifi-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Issue to see ath0 after building madwifi on Debian

Pavel Roskin
Hi Sebastien,

Quoting "Cayetanot, Sebastien" <[hidden email]>:

> Ok , I have patched the source code of the madwifi driver to replace  
>  skb_append by skb_queue_after and the build succeed.
>
> Now, when I load the ath_hal module, I got a reply in dmesg with:  
> ath_hal: 0.9.18.0 (AR5210....)

It would be nice if you wrote everything in one message.  It's hard to  
understand what you have downloaded and patched.  I believe you should  
not have to patch the current snapshot from the 0.9.4 branch:

http://snapshots.madwifi-project.org/madwifi-0.9.4-current.tar.gz

If you are having compile problems with it, please let me know.  I'll  
try to fix it.

> But when loading the ath_pci module, I got a list of "unknown symbol  
>  ieeexxx" and "disagrees about version of symbol and FATAL error to  
> load the module

Please don't rephrase error messages.  It makes it harder to find out  
what is going on.  It's better that you give one error message exactly  
as is.

I believe you may have some modules loaded from another version of  
MadWifi.  You can run madwifi-unload or reboot the system to make sure  
those modules are not loaded.  I hope you are using "make install" to  
install the modules.

--
Regards,
Pavel Roskin

------------------------------------------------------------------------------
Own the Future-Intel&reg; Level Up Game Demo Contest 2013
Rise to greatness in Intel's independent game demo contest.
Compete for recognition, cash, and the chance to get your game
on Steam. $5K grand prize plus 10 genre and skill prizes.
Submit your demo by 6/6/13. http://p.sf.net/sfu/intel_levelupd2d
_______________________________________________
Madwifi-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/madwifi-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Issue to see ath0 after building madwifi on Debian

Cayetanot, Sebastien
Sorry about that.

I'm progressing but I more and more sure that it's linked to modules which are not loaded at boot.

I have fixed all issues on unknown symbols when I have loaded the cfg80211 module. It could be possible that by default I do not have all modules loaded to manage wireless support.

For the moment, I have manually loaded cfg80211, wlan, ath_* and all modules are loaded without error. I still not have my interface seen but issues are fixed.

Seb

-----Original Message-----
From: Pavel Roskin [mailto:[hidden email]]
Sent: Wednesday, March 27, 2013 3:15 PM
To: Cayetanot, Sebastien
Cc: [hidden email]
Subject: RE: [Madwifi-users] Issue to see ath0 after building madwifi on Debian

Hi Sebastien,

Quoting "Cayetanot, Sebastien" <[hidden email]>:

> Ok , I have patched the source code of the madwifi driver to replace  
> skb_append by skb_queue_after and the build succeed.
>
> Now, when I load the ath_hal module, I got a reply in dmesg with:  
> ath_hal: 0.9.18.0 (AR5210....)

It would be nice if you wrote everything in one message.  It's hard to understand what you have downloaded and patched.  I believe you should not have to patch the current snapshot from the 0.9.4 branch:

http://snapshots.madwifi-project.org/madwifi-0.9.4-current.tar.gz

If you are having compile problems with it, please let me know.  I'll try to fix it.

> But when loading the ath_pci module, I got a list of "unknown symbol  
>  ieeexxx" and "disagrees about version of symbol and FATAL error to  
> load the module

Please don't rephrase error messages.  It makes it harder to find out what is going on.  It's better that you give one error message exactly as is.

I believe you may have some modules loaded from another version of MadWifi.  You can run madwifi-unload or reboot the system to make sure those modules are not loaded.  I hope you are using "make install" to install the modules.

--
Regards,
Pavel Roskin
---------------------------------------------------------------------
Intel Corporation SAS (French simplified joint stock company)
Registered headquarters: "Les Montalets"- 2, rue de Paris,
92196 Meudon Cedex, France
Registration Number:  302 456 199 R.C.S. NANTERRE
Capital: 4,572,000 Euros

This e-mail and any attachments may contain confidential material for
the sole use of the intended recipient(s). Any review or distribution
by others is strictly prohibited. If you are not the intended
recipient, please contact the sender and delete all copies.
------------------------------------------------------------------------------
Own the Future-Intel&reg; Level Up Game Demo Contest 2013
Rise to greatness in Intel's independent game demo contest.
Compete for recognition, cash, and the chance to get your game
on Steam. $5K grand prize plus 10 genre and skill prizes.
Submit your demo by 6/6/13. http://p.sf.net/sfu/intel_levelupd2d
_______________________________________________
Madwifi-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/madwifi-users
Loading...