Cannot make my Atheros based card to work as access point

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Cannot make my Atheros based card to work as access point

Владимир Р
Pavel Roskin wrote:
>I just checked backtrack 3 final with the same commands,
>and a Linux station connected automatically.  
>I could ping it would doing anything else.  
>I think the software is OK on the AP side.  Please check antennas.  
>Use packet sniffers like wireshark to see if the beacons are sent.  
>Try capturing the whole association process.
I downloaded madwifi-trunk-r3767-20080711.tar.gz and
compiled it on backtrack 3 final.
After unloading supplied with release madwifi modules and
loading compiled ones, I could setup access point with same commands.
But it behaves just like in beta release: I can see it, I can connect it,
but connection drops every 5 seconds.
Trying to use Bt3final as-is, I can see no AP, with same antenna, WiFi card, PC, etc.
  So my question is: was it sufficient
to make access point only run mentioned commands.
----------------
wlanconfig ath0 create wlandev wifi0 wlanmode ap
iwconfig ath0 mode master
iwconfig ath0 channel 3
iwconfig ath0 essid mytestap
ifconfig ath0 inet 192.168.123.1 netmask 255.255.255.0 up
-----------------
Or I must use some additional software (something like hostapd).
I want get very basic access point, without any encryption,
just to see and test possibilities.
 

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Madwifi-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/madwifi-users
Reply | Threaded
Open this post in threaded view
|

Re: Cannot make my Atheros based card to work as access point

Pavel Roskin
On Sat, 2008-07-19 at 16:43 +0400, Vladimir R wrote:

>   So my question is: was it sufficient
> to make access point only run mentioned commands.
> ----------------
> wlanconfig ath0 create wlandev wifi0 wlanmode ap
> iwconfig ath0 mode master
> iwconfig ath0 channel 3
> iwconfig ath0 essid mytestap
> ifconfig ath0 inet 192.168.123.1 netmask 255.255.255.0 up
> -----------------
> Or I must use some additional software (something like hostapd).
> I want get very basic access point, without any encryption,
> just to see and test possibilities.

It should be sufficient.

--
Regards,
Pavel Roskin

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Madwifi-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/madwifi-users